USB Arducam B0200

Dear,

Do anyone of you have experience in connect USB Arducam B0200 to OpenHD ?
Here is link for short description:
https://www.arducam.com/product/arducam-1080p-low-light-wdr-usb-camera-module-for-computer-2mp-1-2-8-cmos-imx291-100-degree-wide-angle-mini-uvc-spy-webcam-board-with-microphone-3-3ft-1m-cable-for-windows-linux-mac-os/

I have done config for airPi according to IP/USB manual.
In openhd-settings-1.txt file there is default settings for gst-launch … like this:
USBCamera="gst-launch-1.0 uvch264src device=/dev/video1 initial-bitrate=$1 average-bitrate=$1 iframe-period=1000 name=src auto-start=true src.vidsrc ! queue ! video/x-h264,width=1280,height=720,framerate=30/1 ! h264parse ! rtph264pay
Above settings doesn’t work for me.

ArduCam B0200 have two devices in /dev/. Video0 is for MJPEG, video1 is for H.264
My USBCamera string looks like this: USBCamera=“gst-launch-1.0 v4l2src device=/dev/video1 ! queue ! video/x-h264,width=1280,height=720 ! h264parse ! rtph264pay ! udpsink host=127.0.0.1 port=5600”

But still not work.
On airPi gst-launch process start propperly but on groundPi no video. Telemetry works fine.

Do you have any idea ???

Regards,
Radek

Hi :slight_smile:

Yes there’s a tiny bug that affects single USB/IP cameras at the moment, I should have time to track it down later today.

Hey can you try setting IsCamera1Enabled=1 on the air side in openhd-settings-1.txt?

edit: just did some more testing, there is 1 change needed aside from that setting, I will fix it up and everything will be working in rc8 tomorrow.

I found the bug just tracking down the best way to fix it.

is this fixed? same issue here. single USB cam fails to work

It should be working, which OSD are you using on the ground?

I’m using a PI4 with the default image (buster) on the ground station, and a PI4 with buster on the Air unit. PI Cam works, but when I use a USB cam (Logitech C900), and create the file ‘Air.txt’ on the air station, the camera is streaming, but I get no image on the GS. I verified the gstreamer pipe is correct, and I can display the image on the air unit screen.

Is there a setting on the GS to enable the single USB camera?

Thanks,
Patrick

Has anybody resolved this issue?
I have the same problem by using the gstreamer test source instead of usbcam

I use the v202 (Buster) prebuild image, startup everything works perfect with raspicam.
Now i followed the guide to use USB cam
create air.txt
SecondaryCamera=USB
IsCamera1Enabled=1
USBCamera=“gst-launch-1.0 videotestsrc ! video/x-raw,width=160,height=120,framerate=30/1 ! videoconvert ! v4l2h264enc ! h264parse config-interval=3 ! rtph264pay ! udpsink host=127.0.0.1 port=5600”

startup again, now video at all
what could be the reason for that?
use qopenhd on ground pi and on android phone also nothing on

EXPERIMENTAL Secondary IP/USB Camera UDP Port (DON’T CHANGE)

VIDEO_UDP_PORT2=5601

my setup:
Ground:
Raspi3+
2WN722N
Air:
Raspi4
1 AWUS036NHA

Try turning the band switcher on as well.