Seems to have no connection on TL-WN722N v1.2

Hello,
I tried to run the system without success and I got to the point where I have to ask for help.
There is only black image with default OSD, I see -126 dBm on transmit and receive despite log shows that Air PI was found and telemetry is transmitted. Also temperature and load of Air PI is read as 0. Actualy image looks the same despite Air PI is powered or not. The instalation is 2.0.8

Setup:
Ground PI 3B+, TL-WN722N v1.2 soldered to micro usb power pads, powered by original RPI power adapter.
Air PI 4B, TL-WN722N v1.2 soldered to usb C power pads, powered by similar to original RPI power adapter, Wavehare TC358743 HDMI to CSI converter with Gopro Hero7. Also configured camera settings as suggested in config file.

I also made antenna mod on both TL-WN722N as suggested in WiFi adapters section.

I was able to confirm on Raspian installation that Wavehare TC358743 HDMI to CSI converter with Gopro Hero7 is sending image to RPI (also confirmed that with Hero3).

I suspect issue with the WiFi adapter, meanwhile I’m waiting for “blue sticks” from aliexpress.

Any ideas what else can I check? Or just TL-WN722N is a rubbish?

Seems I have to answer myself. I switched RPIs - used RPI4 as ground station and RPI3B+ as AIR and everything is magically working (even gopro hero7!). Strange, I expected RPI3B+ to be working fine as Ground Station (full size HDMI is advantage).

mroowa_fpv

Hello, Curious. what are the ‘blue sticks’ you are speaking of,oder from Aliexpress?

Thanks

This one AR9271 150M wireless network card module High power usb wireless network card Wifi receiver super long distance|Replacement Parts & Accessories| - AliExpress
It is listed on recommended WIFI adapters list

mroowa_fpv

Thank You,
Now I know… May have to try a pair of these… wish i knew more about the inner working of all of these various wifi cards,in regards to possible power outputs… Atheros seems to be very much a leader in this market…

Thanks again