AWB change in RC6

Hello guys, nice place here :slightly_smiling_face:

I have one problem with RC6
Since RC6 the AWB seems off when using PiHQ camera.

changing -awb cloud/auto/horizon in Extraparams does not help.

RC5 nice colours:

RC6 red-ish colours:

Maybe somebody knows what’s going on.

Best greetings
CG

From what I saw the new AWB thing is mostly about the rate of change in auto AWB mode in raspivid, when the scene changes rapidly it’s a little more smooth.

If it’s causing problems we can disable it again.

Going back sounds like the way to go here. I never had any issues with the old one.
Maybe some other users could state if they have similar problems or benefit from the new one.

Originally we had to disable the new AWB because the pi engineers completely broke stereopi somehow, they fixed that recently so we turned it back on. Perhaps making it a setting would be the best thing to do but disable it by default while I figure out if it’s really supposed to be doing the redshift thing or not.

If it’s possible to make it a setting - that whould be ideal.

Should be fixed in rc7

Yea, thanks Stephen :+1::+1::+1:

I don’t know if this is any help but:

The same issue can be seen in standard raspiOS buster.

It seems to be an issue with my aftermarket IR-Filter. The original should work just fine (not tested by me)
Im in contact with some raspi-people and try to find out more :innocent:

„Prototype of a Arducam M12 imx477r camera which has the same issue“

Just for the record:

All these issues can be avoided by using the HQ‘s original blue-ish IR filter.

More informations on how to solve this issue in software can be found here:

And here is a thread in which this issue was addressed and solved by the raspi people: